Vulnerability · Published Sep 8, 2025 · Assigned by GitHub_M
CVE-2025-58365XWiki Blog Application: Privilege Escalation (PR) from account through blog content
High 8.7
In plain English
A high-severity security flaw in application-blog from xwiki-contrib. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The XWiki blog application allows users of the XWiki platform to create and manage blog posts. Prior to version 9.14, the blog application in XWiki allowed remote code execution for any user who has edit right on any page. Normally, these are all logged-in users as they can edit their own user profile. For an exploit, it is sufficient to add an object of type `Blog.BlogPostClass` to any page and to add some script macro with the exploit code to the "Content" field of that object. The vulnerability has been patched in the blog application version 9.14 by executing the content of blog posts with the rights of the appropriate author. No known workarounds are available.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.xwiki.contrib.blog:application-blog-ui | 9.14 | GHSA-gwj6-xpfg-pxwr |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| xwiki-contrib | application-blog | < 9.14 |
Weakness: CWE-95 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N