Actively exploited · Published Nov 25, 2025 · Assigned by GitHub_M
CVE-2025-58360GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature
High 8.2 Exploited
In plain English
A high-severity XML external entity in geoserver from geoserver. Attackers are actively exploiting it in the wild (listed by CISA on December 11, 2025). The chance it is exploited in the next 30 days is estimated at 61.2% (higher than 99.2% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
CISA guidance
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Federal agencies must remediate by Jan 1, 2026.
Official description
GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.geoserver.web:gs-web-app | 2.26.2 | GHSA-fjf5-xgmq-5525 |
| Maven | org.geoserver.web:gs-web-app | 2.25.6 | GHSA-fjf5-xgmq-5525 |
| Maven | org.geoserver:gs-wms | 2.26.2 | GHSA-fjf5-xgmq-5525 |
| Maven | org.geoserver:gs-wms | 2.25.6 | GHSA-fjf5-xgmq-5525 |
Affected products (as reported)
Weakness: CWE-611 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
References
- https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525 x_refsource_CONFIRM
- https://osgeo-org.atlassian.net/browse/GEOS-11682 x_refsource_MISC
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-58360 government-resource