Vulnerability · Published Dec 5, 2025 · Assigned by apache
CVE-2025-58098Apache HTTP Server: Server Side Includes adds query string to #exec cmd=...
High 8.3
In plain English
A high-severity security flaw in Apache HTTP Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 75% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | httpd | 2.4.37-65.module_el8.10.0+4088+57f011c1.7 | ALSA-2025:23732 |
| AlmaLinux:9 | httpd | 2.4.62-7.el9_7.3 | ALSA-2025:23919 |
| AlmaLinux:9 | httpd-core | 2.4.62-7.el9_7.3 | ALSA-2025:23919 |
| AlmaLinux:8 | httpd-devel | 2.4.37-65.module_el8.10.0+4088+57f011c1.7 | ALSA-2025:23732 |
| AlmaLinux:9 | httpd-devel | 2.4.62-7.el9_7.3 | ALSA-2025:23919 |
| AlmaLinux:10 | httpd-filesystem | 2.4.63-4.el10_1.3 | ALSA-2025:23932 |
| AlmaLinux:8 | httpd-filesystem | 2.4.37-65.module_el8.10.0+4088+57f011c1.7 | ALSA-2025:23732 |
| AlmaLinux:9 | httpd-filesystem | 2.4.62-7.el9_7.3 | ALSA-2025:23919 |
| AlmaLinux:8 | httpd-manual | 2.4.37-65.module_el8.10.0+4088+57f011c1.7 | ALSA-2025:23732 |
| AlmaLinux:9 | httpd-manual | 2.4.62-7.el9_7.3 | ALSA-2025:23919 |
| AlmaLinux:8 | httpd-tools | 2.4.37-65.module_el8.10.0+4088+57f011c1.7 | ALSA-2025:23732 |
| AlmaLinux:9 | httpd-tools | 2.4.62-7.el9_7.3 | ALSA-2025:23919 |
| AlmaLinux:8 | mod_http2 | 1.15.7-10.module_el8.10.0+4044+ea5f78b1.4 | ALSA-2025:23732 |
| AlmaLinux:8 | mod_ldap | 2.4.37-65.module_el8.10.0+4088+57f011c1.7 | ALSA-2025:23732 |
| AlmaLinux:9 | mod_ldap | 2.4.62-7.el9_7.3 | ALSA-2025:23919 |
| AlmaLinux:9 | mod_lua | 2.4.62-7.el9_7.3 | ALSA-2025:23919 |
| AlmaLinux:8 | mod_md | 1:2.0.8-8.module_el8.10.0+4088+57f011c1.2 | ALSA-2025:23732 |
| AlmaLinux:8 | mod_proxy_html | 1:2.4.37-65.module_el8.10.0+4088+57f011c1.7 | ALSA-2025:23732 |
| AlmaLinux:9 | mod_proxy_html | 1:2.4.62-7.el9_7.3 | ALSA-2025:23919 |
| AlmaLinux:8 | mod_session | 2.4.37-65.module_el8.10.0+4088+57f011c1.7 | ALSA-2025:23732 |
| AlmaLinux:9 | mod_session | 2.4.62-7.el9_7.3 | ALSA-2025:23919 |
| AlmaLinux:8 | mod_ssl | 1:2.4.37-65.module_el8.10.0+4088+57f011c1.7 | ALSA-2025:23732 |
| AlmaLinux:9 | mod_ssl | 1:2.4.62-7.el9_7.3 | ALSA-2025:23919 |
| Alpine:v3.20 | apache2 | 2.4.66-r0 | ALPINE-CVE-2025-58098 |
| Alpine:v3.21 | apache2 | 2.4.66-r0 | ALPINE-CVE-2025-58098 |
| Alpine:v3.22 | apache2 | 2.4.66-r0 | ALPINE-CVE-2025-58098 |
| Alpine:v3.23 | apache2 | 2.4.66-r0 | ALPINE-CVE-2025-58098 |
| Alpine:v3.24 | apache2 | 2.4.66-r0 | ALPINE-CVE-2025-58098 |
| Debian:12 | apache2 | 2.4.66-1~deb12u1 | DEBIAN-CVE-2025-58098 |
| Debian:13 | apache2 | 2.4.66-1~deb13u1 | DEBIAN-CVE-2025-58098 |
| Debian:14 | apache2 | 2.4.66-1 | DEBIAN-CVE-2025-58098 |
| Rocky Linux:10 | httpd | 0:2.4.63-4.el10_1.3 | RLSA-2025:23932 |
| Rocky Linux:8 | httpd | 0:2.4.37-65.module+el8.10.0+1938+3b7755d4.3 | RLSA-2025:23732 |
| Rocky Linux:8 | httpd | 0:2.4.37-65.module+el8.10.0+40045+6ce8579b.6 | RLSA-2025:23732 |
| Rocky Linux:8 | httpd | 0:2.4.37-65.module+el8.10.0+1830+22f0c9e0 | RLSA-2025:23732 |
| Rocky Linux:8 | httpd | 0:2.4.37-65.module+el8.10.0+1842+4a9649e8.2 | RLSA-2025:23732 |
| Rocky Linux:8 | httpd | 0:2.4.37-65.module+el8.10.0+1840+b070a976.1 | RLSA-2025:23732 |
| Rocky Linux:8 | httpd | 0:2.4.37-65.module+el8.10.0+2061+8d03fdec.5 | RLSA-2025:23732 |
| Rocky Linux:8 | httpd | 0:2.4.37-65.module+el8.10.0+1984+1bed3124.4 | RLSA-2025:23732 |
| Rocky Linux:9 | httpd | 0:2.4.62-7.el9_7.3 | RLSA-2025:23919 |
| Rocky Linux:8 | mod_http2 | 0:1.15.7-10.module+el8.10.0+1775+6b057638 | RLSA-2025:23732 |
| Rocky Linux:8 | mod_http2 | 0:1.15.7-10.module+el8.10.0+1883+38ed6c58.1 | RLSA-2025:23732 |
| Rocky Linux:8 | mod_http2 | 0:1.15.7-10.module+el8.10.0+1938+3b7755d4.3 | RLSA-2025:23732 |
| Rocky Linux:8 | mod_http2 | 0:1.15.7-10.module+el8.10.0+1830+22f0c9e0 | RLSA-2025:23732 |
| Rocky Linux:8 | mod_http2 | 0:1.15.7-10.module+el8.10.0+2061+8d03fdec.4 | RLSA-2025:23732 |
| Rocky Linux:8 | mod_md | 1:2.0.8-8.module+el8.9.0+1370+89cc8ad5 | RLSA-2025:23732 |
| Ubuntu:22.04:LTS | apache2 | 2.4.52-1ubuntu4.18 | USN-7968-1 |
| Ubuntu:22.04:LTS | apache2 | 2.4.52-1ubuntu4.18 | UBUNTU-CVE-2025-58098 |
| Ubuntu:24.04:LTS | apache2 | 2.4.58-1ubuntu8.10 | USN-7968-1 |
| Ubuntu:24.04:LTS | apache2 | 2.4.58-1ubuntu8.10 | UBUNTU-CVE-2025-58098 |
| Ubuntu:25.10 | apache2 | 2.4.64-1ubuntu3.2 | UBUNTU-CVE-2025-58098 |
| Ubuntu:25.10 | apache2 | 2.4.64-1ubuntu3.2 | USN-7968-1 |
| Ubuntu:26.04:LTS | apache2 | 2.4.66-2ubuntu1 | UBUNTU-CVE-2025-58098 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache HTTP Server | 0 – before 2.4.66 |
Weakness: CWE-201 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L