Vulnerability · Published Aug 29, 2025 · Assigned by GitHub_M
CVE-2025-58066DoS Vulnerability in ntpd-rs
Medium 5.3
In plain English
A medium-severity security flaw in ntpd-rs from pendulum-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. In versions between 1.2.0 and 1.6.1 inclusive servers which allow non-NTS traffic are affected by a denial of service vulnerability, where an attacker can induce a message storm between two NTP servers running ntpd-rs. Client-only configurations are not affected. Affected users are recommended to upgrade to version 1.6.2 as soon as possible.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | rust-ntpd | no fix listed | DEBIAN-CVE-2025-58066 |
| Debian:14 | rust-ntpd | 1.6.2-1 | DEBIAN-CVE-2025-58066 |
| Ubuntu:24.04:LTS | rust-ntpd | no fix listed | UBUNTU-CVE-2025-58066 |
| Ubuntu:25.10 | rust-ntpd | no fix listed | UBUNTU-CVE-2025-58066 |
| Ubuntu:26.04:LTS | rust-ntpd | no fix listed | UBUNTU-CVE-2025-58066 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| pendulum-project | ntpd-rs | >= 1.2.0, < 1.6.2 |
Weakness: CWE-406 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L