Vulnerability · Published Sep 3, 2025 · Assigned by GitHub_M
CVE-2025-58064CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package
Low 2.3
In plain English
A low-severity cross-site scripting in ckeditor5 from ckeditor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @ckeditor/ckeditor5-clipboard | 45.2.2 | GHSA-x9gp-vjh6-3wv6 |
| npm | @ckeditor/ckeditor5-clipboard | 46.0.3 | GHSA-x9gp-vjh6-3wv6 |
| npm | ckeditor5 | 46.0.3 | GHSA-x9gp-vjh6-3wv6 |
| npm | ckeditor5 | 45.2.2 | GHSA-x9gp-vjh6-3wv6 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N