Vulnerability · Published Aug 25, 2025 · Assigned by GitHub_M

CVE-2025-57811Craft Potential Remote Code Execution via Twig SSTI

Medium 6.1

In plain English

A medium-severity security flaw in cms from craftcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.1Medium
Exploit odds (30 days)0.9%top 38.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Craft is a platform for creating digital experiences. From versions 4.0.0-RC1 to 4.16.5 and 5.0.0-RC1 to 5.8.6, there is a potential remote code execution vulnerability via Twig SSTI (Server-Side Template Injection). This is a follow-up to CVE-2024-52293. This vulnerability has been patched in versions 4.16.6 and 5.8.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcraftcms/cms4.16.6GHSA-crcq-738g-pqvc
Packagistcraftcms/cms5.8.7GHSA-crcq-738g-pqvc

Affected products (as reported)

VendorProductVersions
craftcms cms >= 4.0.0-RC1, < 4.16.6>= 5.0.0-RC1, < 5.8.7

Weakness: CWE-1336 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

References