Vulnerability · Published Jun 11, 2025 · Assigned by mozilla
CVE-2025-5687Local privilege escalation vulnerability in Mozilla VPN clients for macOS v2.27.0 and below.
High 7.8
In plain English
A high-severity privilege mismanagement in Mozilla VPN 2.28.0 from Mozilla. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities).
Severity (CVSS 3.1)7.8High
Exploit odds (30 days)0.1%top 97.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
A vulnerability in Mozilla VPN on macOS allows privilege escalation from a normal user to root. *This bug only affects Mozilla VPN on macOS. Other operating systems are unaffected.*. This vulnerability was fixed in Mozilla VPN 2.28.0 (macOS).
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Mozilla | Mozilla VPN 2.28.0 | see references |
Weakness: CWE-269 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H