Vulnerability · Published Oct 27, 2025 · Assigned by apache
CVE-2025-55754Apache Tomcat: console manipulation via escape sequences in log messages
Critical 9.6
In plain English
A critical-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 10.3% (higher than 96% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | tomcat | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-admin-webapps | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-docs-webapp | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-el-3.0-api | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-jsp-2.3-api | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-lib | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-servlet-4.0-api | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-webapps | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| Debian:12 | tomcat10 | 10.1.52-1~deb12u1 | DSA-6120-1 |
| Debian:12 | tomcat10 | 10.1.52-1~deb12u1 | DEBIAN-CVE-2025-55754 |
| Debian:13 | tomcat10 | 10.1.52-1~deb13u1 | DEBIAN-CVE-2025-55754 |
| Debian:13 | tomcat10 | 10.1.52-1~deb13u1 | DSA-6120-1 |
| Debian:14 | tomcat10 | 10.1.46-1 | DEBIAN-CVE-2025-55754 |
| Debian:13 | tomcat11 | 11.0.15-1~deb13u1 | DEBIAN-CVE-2025-55754 |
| Debian:13 | tomcat11 | 11.0.15-1~deb13u1 | DSA-6121-1 |
| Debian:14 | tomcat11 | 11.0.11-1 | DEBIAN-CVE-2025-55754 |
| Debian:12 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-55754 |
| Debian:13 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-55754 |
| Debian:14 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-55754 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 9.0.109 | GHSA-vfww-5hm6-hx2j |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 10.1.45 | GHSA-vfww-5hm6-hx2j |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 11.0.11 | GHSA-vfww-5hm6-hx2j |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | no fix listed | GHSA-vfww-5hm6-hx2j |
| Maven | org.apache.tomcat:tomcat | 9.0.109 | GHSA-vfww-5hm6-hx2j |
| Maven | org.apache.tomcat:tomcat | 10.1.45 | GHSA-vfww-5hm6-hx2j |
| Maven | org.apache.tomcat:tomcat | 11.0.11 | GHSA-vfww-5hm6-hx2j |
| Maven | org.apache.tomcat:tomcat | no fix listed | GHSA-vfww-5hm6-hx2j |
| Maven | org.apache.tomcat:tomcat-catalina | 10.1.45 | GHSA-vfww-5hm6-hx2j |
| Maven | org.apache.tomcat:tomcat-catalina | 11.0.11 | GHSA-vfww-5hm6-hx2j |
| Maven | org.apache.tomcat:tomcat-catalina | 9.0.109 | GHSA-vfww-5hm6-hx2j |
| Maven | org.apache.tomcat:tomcat-catalina | no fix listed | GHSA-vfww-5hm6-hx2j |
| Rocky Linux:10 | tomcat | 1:10.1.49-1.el10_2.1 | RLSA-2026:18537 |
| Ubuntu:24.04:LTS | tomcat10 | no fix listed | UBUNTU-CVE-2025-55754 |
| Ubuntu:25.10 | tomcat10 | no fix listed | UBUNTU-CVE-2025-55754 |
| Ubuntu:26.04:LTS | tomcat10 | no fix listed | UBUNTU-CVE-2025-55754 |
| Ubuntu:25.10 | tomcat11 | no fix listed | UBUNTU-CVE-2025-55754 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Tomcat | 11.0.0-M1 – through 11.0.1010.1.0-M1 – through 10.1.449.0.40 – through 9.0.1088.5.60 – through 8.5.100 |
Weakness: CWE-150 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H