Vulnerability · Published Aug 14, 2025 · Assigned by apache

CVE-2025-55672Apache Superset: Stored XSS on charts metadata

Medium 5.3

In plain English

A medium-severity security flaw in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.8%top 43.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A stored Cross-Site Scripting (XSS) vulnerability exists in Apache Superset's chart visualization. An authenticated user with permissions to edit charts can inject a malicious payload into a column's label. The payload is not properly sanitized and gets executed in the victim's browser when they hover over the chart, potentially leading to session hijacking or the execution of arbitrary commands on behalf of the user. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-superset5.0.0GHSA-fj97-2v9x-w5m4
PyPIapache-superset5.0.0PYSEC-2026-1176

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Superset 0 – before 5.0.0

Weakness: CWE-80 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:L/SA:N

References