Vulnerability · Published Aug 18, 2025 · Assigned by GitHub_M
CVE-2025-55287Genealogy has a stored XSS vulnerability
High 8.0
In plain English
A high-severity cross-site scripting in genealogy from MGeurts. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code.
Official description
Genealogy is a family tree PHP application. Prior to 4.4.0, Authenticated Stored Cross-Site Scripting (XSS) vulnerability was identified in the Genealogy application. Authenticated attackers could run arbitrary JavaScript in another user’s session, leading to session hijacking, data theft, and UI manipulation. This vulnerability is fixed in 4.4.0.
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H