Vulnerability · Published Aug 13, 2025 · Assigned by GitHub_M
CVE-2025-55198Helm May Panic Due To Incorrect YAML Content
Medium 6.5
In plain English
A medium-severity security flaw in helm from helm. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Helm is a package manager for Charts for Kubernetes. Prior to version 3.18.5, when parsing Chart.yaml and index.yaml files, an improper validation of type error can lead to a panic. This issue has been resolved in Helm 3.18.5. A workaround involves ensuring YAML files are formatted as Helm expects prior to processing them with Helm.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | helm.sh/helm | no fix listed | GO-2025-3888 |
| Go | helm.sh/helm/v3 | 3.18.5 | GHSA-f9f8-9pmf-xv68 |
| Go | helm.sh/helm/v3 | 3.18.5 | GO-2025-3888 |
Affected products (as reported)
Weakness: CWE-908 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
References
- https://github.com/helm/helm/security/advisories/GHSA-f9f8-9pmf-xv68 x_refsource_CONFIRM
- https://github.com/helm/helm/commit/ec5f59e2db56533d042a124f5bae54dd87b558e6 x_refsource_MISC