Vulnerability · Published Aug 13, 2025 · Assigned by GitHub_M

CVE-2025-55193Active Record logging vulnerable to ANSI escape injection

Low 2.7

In plain English

A low-severity security flaw in rails from rails. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.7Low
Exploit odds (30 days)0.6%top 49.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Active Record connects classes to relational database tables. Prior to versions 7.1.5.2, 7.2.2.2, and 8.0.2.1, the ID passed to find or similar methods may be logged without escaping. If this is directly to the terminal it may include unescaped ANSI sequences. This issue has been patched in versions 7.1.5.2, 7.2.2.2, and 8.0.2.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rails2:6.1.7.10+dfsg-1~deb12u2DSA-6090-1
Debian:12rails2:6.1.7.10+dfsg-1~deb12u2DEBIAN-CVE-2025-55193
Debian:13rails2:7.2.2.2+dfsg-2~deb13u1DEBIAN-CVE-2025-55193
Debian:13rails2:7.2.2.2+dfsg-2~deb13u1DSA-6090-1
Debian:14rails2:7.2.2.2+dfsg-1DEBIAN-CVE-2025-55193
RubyGemsactiverecord7.1.5.2GHSA-76r7-hhxj-r776
RubyGemsactiverecord8.0.2.1GHSA-76r7-hhxj-r776
RubyGemsactiverecord7.2.2.2GHSA-76r7-hhxj-r776
Ubuntu:24.04:LTSrailsno fix listedUBUNTU-CVE-2025-55193
Ubuntu:25.10railsno fix listedUBUNTU-CVE-2025-55193
Ubuntu:26.04:LTSrailsno fix listedUBUNTU-CVE-2025-55193
Ubuntu:26.10railsno fix listedUBUNTU-CVE-2025-55193

Affected products (as reported)

VendorProductVersions
rails rails >= 0, < 7.1.5.2>= 7.2, < 7.2.2.2>= 8.0, < 8.0.2.1

Weakness: CWE-150 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N/E:U

References