Vulnerability · Published Sep 1, 2025 · Assigned by GitHub_M
CVE-2025-55007Knowage vulnerable to server-side request forgery
Low 3.5
In plain English
A low-severity server-side request forgery in Knowage-Server from KnowageLabs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities).
Official description
Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, Knowage is vulnerable to server-side request forgery. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker could be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| KnowageLabs | Knowage-Server | < 8.1.37 |
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N