Vulnerability · Published Aug 9, 2025 · Assigned by GitHub_M

CVE-2025-54998OpenBao Userpass and LDAP User Lockout Bypass

Medium 5.3

In plain English

A medium-severity security flaw in openbao from openbao. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.2%top 85.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 0.1.0 through 2.3.1, attackers could bypass the automatic user lockout mechanisms in the OpenBao Userpass or LDAP auth systems. This was caused by different aliasing between pre-flight and full login request user entity alias attributions. This is fixed in version 2.3.2. To work around this issue, existing users may apply rate-limiting quotas on the authentication endpoints:, see https://openbao.org/api-docs/system/rate-limit-quotas/.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.22openbao2.3.2-r0ALPINE-CVE-2025-54998
Alpine:v3.23openbao2.3.2-r0ALPINE-CVE-2025-54998
Alpine:v3.24openbao2.3.2-r0ALPINE-CVE-2025-54998
Gogithub.com/openbao/openbao2.3.2GHSA-j3xv-7fxp-gfhx
Gogithub.com/openbao/openbao0.0.0-20250807212521-c52795c1ef74GHSA-j3xv-7fxp-gfhx
Gogithub.com/openbao/openbao0.0.0-20250807212521-c52795c1ef74GO-2025-3855

Affected products (as reported)

VendorProductVersions
openbao openbao >= 0.1.0, < 2.3.2

Weakness: CWE-307 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

References