Vulnerability · Published Aug 20, 2025 · Assigned by apache
CVE-2025-54988Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA
High 8.4
In plain English
A high-severity XML external entity in Apache Tika PDF parser module from Apache Software Foundation. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 47.9% (higher than 99% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.tika:tika-parser-pdf-module | 3.2.2 | GHSA-p72g-pv48-7w9x |
| Maven | org.apache.tika:tika-parsers | 2.0.0-ALPHA | GHSA-p72g-pv48-7w9x |
| Ubuntu:22.04:LTS | tika | 1.22-2+deb11u1build0.22.04.1 | UBUNTU-CVE-2025-54988 |
| Ubuntu:22.04:LTS | tika | 1.22-2+deb11u1build0.22.04.1 | USN-8324-1 |
| Ubuntu:24.04:LTS | tika | no fix listed | UBUNTU-CVE-2025-54988 |
| Ubuntu:25.10 | tika | no fix listed | UBUNTU-CVE-2025-54988 |
| Ubuntu:26.04:LTS | tika | no fix listed | UBUNTU-CVE-2025-54988 |
| Ubuntu:26.10 | tika | no fix listed | UBUNTU-CVE-2025-54988 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Tika PDF parser module | 1.13 – through 3.2.1 |
Weakness: CWE-611 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H