Vulnerability · Published Aug 5, 2025 · Assigned by GitHub_M
CVE-2025-54884Vision UI security-kit.js: Potential Uncontrolled Resource Allocation Vulnerability
High 8.7
In plain English
A high-severity uncontrolled resource consumption in Vision-ui from DavidOsipov. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities).
Official description
Vision UI is a collection of enterprise-grade, dependency-free modules for modern web projects. In versions 1.4.0 and below, the generateSecureId and getSecureRandomInt functions in security-kit versions prior to 3.5.0 (packaged in Vision UI 1.4.0 and below) are vulnerable to Denial of Service (DoS) attacks. The generateSecureId(length) function directly used the length parameter to size a Uint8Array buffer, allowing attackers to exhaust server memory through repeated requests for large IDs since the previous 1024 limit was insufficient. The getSecureRandomInt(min, max) function calculated buffer size based on the range between min and max, where large ranges caused excessive memory allocation and CPU-intensive rejection-sampling loops that could hang the thread. This issue is fixed in version 1.5.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| DavidOsipov | Vision-ui | < 1.5.0 |
Weakness: CWE-400, CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N