Vulnerability · Published Aug 19, 2025 · Assigned by GitHub_M

CVE-2025-54880Mermaid does not properly sanitize architecture diagram iconText leading to XSS

Medium 5.1

In plain English

A medium-severity cross-site scripting in mermaid from mermaid-js. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.1Medium
Exploit odds (30 days)0.4%top 64.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Mermaid is a JavaScript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. In the default configuration of mermaid 11.9.0 and earlier, user supplied input for architecture diagram icons is passed to the d3 html() method, creating a sink for cross site scripting. This vulnerability is fixed in 11.10.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:22.04:LTSnode-mermaidno fix listedUBUNTU-CVE-2025-54880
Ubuntu:26.10node-mermaidno fix listedUBUNTU-CVE-2025-54880
npmmermaid11.10.0GHSA-8gwm-58g9-j8pw

Affected products (as reported)

VendorProductVersions
mermaid-js mermaid >= 11.1.0, < 11.10.0

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

References