Vulnerability · Published Aug 5, 2025 · Assigned by GitHub_M
CVE-2025-54869FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser
Medium 6.0
In plain English
A medium-severity resource allocation without limits in FPDI from Setasign. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | icingaweb2-module-pdfexport | no fix listed | DEBIAN-CVE-2025-54869 |
| Debian:13 | icingaweb2-module-pdfexport | no fix listed | DEBIAN-CVE-2025-54869 |
| Debian:14 | icingaweb2-module-pdfexport | no fix listed | DEBIAN-CVE-2025-54869 |
| Packagist | setasign/fpdi | 2.6.4 | GHSA-jxhh-4648-vpp3 |
| Ubuntu:22.04:LTS | icingaweb2-module-pdfexport | no fix listed | UBUNTU-CVE-2025-54869 |
| Ubuntu:24.04:LTS | icingaweb2-module-pdfexport | no fix listed | UBUNTU-CVE-2025-54869 |
| Ubuntu:25.10 | icingaweb2-module-pdfexport | no fix listed | UBUNTU-CVE-2025-54869 |
| Ubuntu:26.04:LTS | icingaweb2-module-pdfexport | no fix listed | UBUNTU-CVE-2025-54869 |
| Ubuntu:26.10 | icingaweb2-module-pdfexport | no fix listed | UBUNTU-CVE-2025-54869 |
Affected products (as reported)
Weakness: CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N