Vulnerability · Published Aug 7, 2025 · Assigned by GitHub_M

CVE-2025-54799Lego does not enforce HTTPS

Low 2.3

In plain English

A low-severity security flaw in lego from go-acme. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.3Low
Exploit odds (30 days)0.2%top 85.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Let's Encrypt client and ACME library written in Go (Lego). In versions 4.25.1 and below, the github.com/go-acme/lego/v4/acme/api package (thus the lego library and the lego cli as well) don't enforce HTTPS when talking to CAs as an ACME client. Unlike the http-01 challenge which solves an ACME challenge over unencrypted HTTP, the ACME protocol requires HTTPS when a client communicates with the CA to performs ACME functions. However, the library fails to enforce HTTPS both in the original discover URL (configured by the library user) and in the subsequent addresses returned by the CAs in the directory and order objects. If users input HTTP URLs or CAs misconfigure endpoints, protocol operations occur over HTTP instead of HTTPS. This compromises privacy by exposing request/response details like account and request identifiers to network attackers. This was fixed in version 4.25.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12golang-github-xenolf-legono fix listedDEBIAN-CVE-2025-54799
Debian:13golang-github-xenolf-legono fix listedDEBIAN-CVE-2025-54799
Debian:14golang-github-xenolf-lego4.35.2-1DEBIAN-CVE-2025-54799
Gogithub.com/go-acme/legono fix listedGHSA-q82r-2j7m-9rv4
Gogithub.com/go-acme/lego/v3no fix listedGHSA-q82r-2j7m-9rv4
Gogithub.com/go-acme/lego/v44.25.2GHSA-q82r-2j7m-9rv4
Gogithub.com/go-acme/lego/v44.25.2GO-2025-3847
Ubuntu:22.04:LTSgolang-github-xenolf-legono fix listedUBUNTU-CVE-2025-54799
Ubuntu:25.10golang-github-xenolf-legono fix listedUBUNTU-CVE-2025-54799
Ubuntu:26.04:LTSgolang-github-xenolf-legono fix listedUBUNTU-CVE-2025-54799
Ubuntu:26.10golang-github-xenolf-legono fix listedUBUNTU-CVE-2025-54799

Affected products (as reported)

VendorProductVersions
go-acme lego < 4.25.2

Weakness: CWE-319 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U

References