Vulnerability · Published Aug 14, 2025 · Assigned by GitHub_M
CVE-2025-54389AIDE improper output neutralization vulnerability
Medium 6.2
In plain English
A medium-severity security flaw in aide from aide. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
AIDE is an advanced intrusion detection environment. Prior to version 0.19.2, there is an improper output neutralization vulnerability in AIDE. An attacker can craft a malicious filename by including terminal escape sequences to hide the addition or removal of the file from the report and/or tamper with the log output. A local user might exploit this to bypass the AIDE detection of malicious files. Additionally the output of extended attribute key names and symbolic links targets are also not properly neutralized. This issue has been patched in version 0.19.2. A workaround involves configuring AIDE to write the report output to a regular file, redirecting stdout to a regular file, or redirecting the log output written to stderr to a regular file.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | aide | 0.18.6-8.el10_0.2 | ALSA-2025:14592 |
| AlmaLinux:8 | aide | 0.16-15.el8_10.2 | ALSA-2025:14573 |
| AlmaLinux:9 | aide | 0.16-103.el9_6.2 | ALSA-2025:14493 |
| Debian:12 | aide | 0.18.3-1+deb12u4 | DEBIAN-CVE-2025-54389 |
| Debian:12 | aide | 0.18.3-1+deb12u4 | DSA-5977-1 |
| Debian:13 | aide | 0.19.1-2+deb13u1 | DSA-5977-1 |
| Debian:13 | aide | 0.19.1-2+deb13u1 | DEBIAN-CVE-2025-54389 |
| Debian:14 | aide | 0.19.2-1 | DEBIAN-CVE-2025-54389 |
| Rocky Linux:10 | aide | 0:0.18.6-8.el10_0.2 | RLSA-2025:14592 |
| Rocky Linux:8 | aide | 0:0.16-15.el8_10.2 | RLSA-2025:14573 |
| Rocky Linux:9 | aide | 0:0.16-103.el9_6.2 | RLSA-2025:14493 |
| Ubuntu:22.04:LTS | aide | 0.17.4-1ubuntu0.2 | UBUNTU-CVE-2025-54389 |
| Ubuntu:22.04:LTS | aide | 0.17.4-1ubuntu0.2 | USN-7697-1 |
| Ubuntu:24.04:LTS | aide | 0.18.6-2ubuntu0.1 | USN-7697-1 |
| Ubuntu:24.04:LTS | aide | 0.18.6-2ubuntu0.1 | UBUNTU-CVE-2025-54389 |
Affected products (as reported)
Weakness: CWE-117 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
References
- https://github.com/aide/aide/security/advisories/GHSA-522j-vvx9-gg28 x_refsource_CONFIRM
- https://github.com/aide/aide/commit/64c8f32b0349c33fb8382784af468338078851f9 x_refsource_MISC
- https://github.com/aide/aide/releases/tag/v0.19.2 x_refsource_MISC
- https://lists.debian.org/debian-lts-announce/2025/08/msg00011.html
- http://www.openwall.com/lists/oss-security/2025/08/14/7