Vulnerability · Published Jul 30, 2025 · Assigned by GitHub_M
CVE-2025-54388Moby's Firewalld reload makes published container ports accessible from remote hosts
Medium 5.1
In plain English
A medium-severity security flaw in moby from moby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Moby is an open source container framework developed by Docker Inc. that is distributed as Docker Engine, Mirantis Container Runtime, and various other downstream projects/products. In versions 28.2.0 through 28.3.2, when the firewalld service is reloaded it removes all iptables rules including those created by Docker. While Docker should automatically recreate these rules, versions before 28.3.3 fail to recreate the specific rules that block external access to containers. This means that after a firewalld reload, containers with ports published to localhost (like 127.0.0.1:8080) become accessible from remote machines that have network routing to the Docker bridge, even though they should only be accessible from the host itself. The vulnerability only affects explicitly published ports - unpublished ports remain protected. This issue is fixed in version 28.3.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.22 | docker | 28.3.3-r0 | ALPINE-CVE-2025-54388 |
| Alpine:v3.23 | docker | 28.3.3-r0 | ALPINE-CVE-2025-54388 |
| Alpine:v3.24 | docker | 28.3.3-r0 | ALPINE-CVE-2025-54388 |
| Go | github.com/docker/docker | 28.3.3+incompatible | GO-2025-3830 |
| Go | github.com/docker/docker | 28.3.3 | GHSA-x4rx-4gw3-53p4 |
| Ubuntu:25.10 | docker.io | no fix listed | UBUNTU-CVE-2025-54388 |
| Ubuntu:26.04:LTS | docker.io | no fix listed | UBUNTU-CVE-2025-54388 |
| Ubuntu:26.10 | docker.io | no fix listed | UBUNTU-CVE-2025-54388 |
| Ubuntu:25.10 | docker.io-app | no fix listed | UBUNTU-CVE-2025-54388 |
| Ubuntu:26.04:LTS | docker.io-app | no fix listed | UBUNTU-CVE-2025-54388 |
Affected products (as reported)
Weakness: CWE-909 · Vector: CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
References
- https://github.com/moby/moby/security/advisories/GHSA-x4rx-4gw3-53p4 x_refsource_CONFIRM
- https://github.com/moby/moby/pull/50506 x_refsource_MISC
- https://github.com/moby/moby/commit/bea959c7b793b32a893820b97c4eadc7c87fabb0 x_refsource_MISC