Vulnerability · Published Aug 1, 2025 · Assigned by GitHub_M

CVE-2025-54386Traefik's Client Plugin is Vulnerable to Path Traversal, Arbitrary File Overwrites and Remote Code Execution

High 7.3

In plain English

A high-severity path traversal in traefik from traefik. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.3High
Exploit odds (30 days)1.4%top 28.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Traefik is an HTTP reverse proxy and load balancer. In versions 2.11.27 and below, 3.0.0 through 3.4.4 and 3.5.0-rc1, a path traversal vulnerability was discovered in WASM Traefik’s plugin installation mechanism. By supplying a maliciously crafted ZIP archive containing file paths with ../ sequences, an attacker can overwrite arbitrary files on the system outside of the intended plugin directory. This can lead to remote code execution (RCE), privilege escalation, persistence, or denial of service. This is fixed in versions 2.11.28, 3.4.5 and 3.5.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/traefik/traefikno fix listedGO-2025-3835
Gogithub.com/traefik/traefik/v22.11.28GHSA-q6gg-9f92-r9wg
Gogithub.com/traefik/traefik/v22.11.28GO-2025-3835
Gogithub.com/traefik/traefik/v33.4.5GHSA-q6gg-9f92-r9wg
Gogithub.com/traefik/traefik/v33.5.0GHSA-q6gg-9f92-r9wg
Gogithub.com/traefik/traefik/v33.4.5, 3.5.0GO-2025-3835

Affected products (as reported)

VendorProductVersions
traefik traefik <= 2.11.27, < 2.11.28<= 3.0.0, < 3.4.5>= 3.5.0-rc1, < 3.5.0-rc2

Weakness: CWE-22, CWE-30 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L

References