Vulnerability · Published Oct 29, 2025 · Assigned by GitHub_M
CVE-2025-54384CKAN stored XSS vulnerability in Markdown description fields
Medium 6.3
In plain English
A medium-severity cross-site scripting in ckan from ckan. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, the helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | ckan | 2.11.4 | GHSA-2r4h-8jxv-w2j8 |
| PyPI | ckan | 2.10.9 | GHSA-2r4h-8jxv-w2j8 |
| PyPI | ckan | 2.10.9, 2.11.4 | PYSEC-2026-1247 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
References
- https://github.com/ckan/ckan/security/advisories/GHSA-2r4h-8jxv-w2j8 x_refsource_CONFIRM
- https://github.com/ckan/ckan/commit/6d0065f2fc7e2682196d125275af34b93e9e554e x_refsource_MISC