Vulnerability · Published Aug 25, 2025 · Assigned by GitHub_M

CVE-2025-54370PhpSpreadsheet vulnerable to SSRF when reading and displaying a processed HTML document in the browser

High 8.7

In plain English

A high-severity server-side request forgery in PhpSpreadsheet from PHPOffice. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.8%top 42.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

PhpOffice/PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0, SSRF can occur when a processed HTML document is read and displayed in the browser. The vulnerability lies in the setPath method of the PhpOffice\PhpSpreadsheet\Worksheet\Drawing class, where a crafted string from the user is passed to the HTML reader. This issue has been patched in versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistphpoffice/phpspreadsheet1.30.0GHSA-rx7m-68vc-ppxh
Packagistphpoffice/phpspreadsheet2.1.12GHSA-rx7m-68vc-ppxh
Packagistphpoffice/phpspreadsheet2.4.0GHSA-rx7m-68vc-ppxh
Packagistphpoffice/phpspreadsheet3.10.0GHSA-rx7m-68vc-ppxh
Packagistphpoffice/phpspreadsheet5.0.0GHSA-rx7m-68vc-ppxh

Affected products (as reported)

VendorProductVersions
PHPOffice PhpSpreadsheet < 1.30.0>= 2.0.0, < 2.1.12>= 2.2.0, < 2.4.0>= 3.0.0, < 3.10.0>= 4.0.0, < 5.0.0

Weakness: CWE-918 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References