Vulnerability · Published Dec 12, 2025 · Assigned by GitHub_M

CVE-2025-54369Node-SAML SAML Authentication Bypass

Critical 9.3

In plain English

A critical-severity security flaw in node-saml from node-saml. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.3Critical
Exploit odds (30 days)0.5%top 54.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Node-SAML is a SAML library not dependent on any frameworks that runs in Node. In versions 5.0.1 and below, Node-SAML loads the assertion from the (unsigned) original response document. This is different than the parts that are verified when checking signature. This allows an attacker to modify authentication details within a valid SAML assertion. For example, in one attack it is possible to remove any character from the SAML assertion username. This issue is fixed in version 5.1.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@node-saml/node-saml5.1.0GHSA-m837-g268-mmv7
npmnode-samlno fix listedGHSA-m837-g268-mmv7

Affected products (as reported)

VendorProductVersions
node-saml node-saml < 5.1.0

Weakness: CWE-87, CWE-347 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References