Vulnerability · Published Aug 8, 2025 · Assigned by GitHub_M

CVE-2025-54368uv is vulnerable to ZIP payload obfuscation through parsing differentials

Medium 6.8

In plain English

A medium-severity improper input validation in uv from astral-sh. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.8Medium
Exploit odds (30 days)0.2%top 87.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

uv is a Python package and project manager written in Rust. In versions 0.8.5 and earlier, remote ZIP archives were handled in a streamwise fashion, and file entries were not reconciled against the archive's central directory. An attacker could contrive a ZIP archive that would extract with legitimate contents on some package installers, and malicious contents on others due to multiple local file entries. An attacker could also contrive a "stacked" ZIP input with multiple internal ZIPs, which would be handled differently by different package installers. The attacker could choose which installer to target in both scenarios. This issue is fixed in version 0.8.6. To work around this issue, users may choose to set UV_INSECURE_NO_ZIP_VALIDATION=1 to revert to the previous behavior.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIuv0.8.6GHSA-8qf3-x8v5-2pj8
PyPIuv0.8.6PYSEC-2026-2001

Affected products (as reported)

VendorProductVersions
astral-sh uv < 0.8.6

Weakness: CWE-436, CWE-20 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

References