Vulnerability · Published Jul 23, 2025 · Assigned by GitHub_M

CVE-2025-54365fastapi-guard patch contains bypassable RegEx

High 7.8

In plain English

A high-severity improper input validation in fastapi-guard from rennf93. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.8High
Exploit odds (30 days)0.9%top 41.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

fastapi-guard is a security library for FastAPI that provides middleware to control IPs, log requests, detect penetration attempts and more. In version 3.0.1, the regular expression patched to mitigate the ReDoS vulnerability by limiting the length of string fails to catch inputs that exceed this limit. This type of patch fails to detect cases in which the string representing the attributes of a <script> tag exceeds 100 characters. As a result, most of the regex patterns present in version 3.0.1 can be bypassed. This is fixed in version 3.0.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIfastapi-guard3.0.2GHSA-rrf6-pxg8-684g
PyPIfastapi-guard3.0.2PYSEC-2026-1360

Affected products (as reported)

VendorProductVersions
rennf93 fastapi-guard >= 3.0.1, < 3.0.2

Weakness: CWE-20, CWE-185 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:P

References