Vulnerability · Published Aug 5, 2025 · Assigned by GitHub_M
CVE-2025-54135Cursor Agent is vulnerable to prompt injection via MCP Special Files
High 8.6
In plain English
A high-severity OS command injection in cursor from cursor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.1% (higher than 82% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code.
Official description
Cursor is a code editor built for programming with AI. Cursor allows writing in-workspace files with no user approval in versions below 1.3.9, If the file is a dotfile, editing it requires approval but creating a new one doesn't. Hence, if sensitive MCP files, such as the .cursor/mcp.json file don't already exist in the workspace, an attacker can chain a indirect prompt injection vulnerability to hijack the context to write to the settings file and trigger RCE on the victim without user approval. This is fixed in version 1.3.9.
Affected products (as reported)
Weakness: CWE-78, CWE-829 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/cursor/cursor/security/advisories/GHSA-4cxx-hrm3-49rm x_refsource_CONFIRM