Vulnerability · Published Jul 21, 2025 · Assigned by GitHub_M

CVE-2025-54134HAX CMS NodeJs's Improper Error Handling Leads to Denial of Service

High 7.1

In plain English

A high-severity improper input validation in issues from haxtheweb. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.5%top 59.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.8 and below, the HAX CMS NodeJS application crashes when an authenticated attacker provides an API request lacking required URL parameters. This vulnerability affects the listFiles and saveFiles endpoints. This vulnerability exists because the application does not properly handle exceptions which occur as a result of changes to user-modifiable URL parameters. This is fixed in version 11.0.9.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@haxtheweb/haxcms-nodejs11.0.9GHSA-pjj3-j5j6-qj27

Affected products (as reported)

VendorProductVersions
haxtheweb issues < 11.0.9

Weakness: CWE-20, CWE-248, CWE-703 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References