Vulnerability · Published Aug 5, 2025 · Assigned by GitHub_M
CVE-2025-54130Cursor Agent is vulnerable prompt injection via Editor Special Files
High 7.5
In plain English
A high-severity security flaw in cursor from cursor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities).
Official description
Cursor is a code editor built for programming with AI. Cursor allows writing in-workspace files with no user approval in versions less than 1.3.9. If the file is a dotfile, editing it requires approval but creating a new one doesn't. Hence, if sensitive editor files, such as the .vscode/settings.json file don't already exist in the workspace, an attacker can chain a indirect prompt injection vulnerability to hijack the context to write to the settings file and trigger RCE on the victim without user approval. This is fixed in version 1.3.9.
Affected products (as reported)
Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/cursor/cursor/security/advisories/GHSA-vqv7-vq92-x87f x_refsource_CONFIRM