Vulnerability · Published Aug 5, 2025 · Assigned by GitHub_M
CVE-2025-54119ADOdb's sqlite3 driver allows SQL injection
Critical 10.0
In plain English
A critical-severity SQL injection in ADOdb from ADOdb. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. In versions 5.22.9 and below, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a sqlite3 database and calls the metaColumns(), metaForeignKeys() or metaIndexes() methods with a crafted table name. This is fixed in version 5.22.10. To workaround this issue, only pass controlled data to metaColumns(), metaForeignKeys() and metaIndexes() method's $table parameter.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | libphp-adodb | 5.21.4-1+deb12u2 | DEBIAN-CVE-2025-54119 |
| Debian:13 | libphp-adodb | 5.22.9-0.1+deb13u1 | DEBIAN-CVE-2025-54119 |
| Debian:14 | libphp-adodb | 5.22.10-0.1 | DEBIAN-CVE-2025-54119 |
| Packagist | adodb/adodb-php | 5.22.10 | GHSA-vf2r-cxg9-p7rf |
| Ubuntu:25.10 | libphp-adodb | no fix listed | UBUNTU-CVE-2025-54119 |
| Ubuntu:26.10 | libphp-adodb | no fix listed | UBUNTU-CVE-2025-54119 |
Affected products (as reported)
Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
References
- https://github.com/ADOdb/ADOdb/security/advisories/GHSA-vf2r-cxg9-p7rf x_refsource_CONFIRM
- https://github.com/ADOdb/ADOdb/issues/1083 x_refsource_MISC
- https://github.com/ADOdb/ADOdb/commit/5b8bd52cdcffefb4ecded1b399c98cfa516afe03 x_refsource_MISC
- https://lists.debian.org/debian-lts-announce/2025/10/msg00020.html