Vulnerability · Published Nov 29, 2025 · Assigned by GitHub_M

CVE-2025-53939Kiteworks Core is vulnerable to Improper Input Validation

Medium 6.3

In plain English

A medium-severity improper input validation in security-advisories from kiteworks. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities).

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)0.8%top 43.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kiteworks is a private data network (PDN). Prior to version 9.1.0, improper input validation when managing roles of a shared folder could lead to unexpectedly elevate another user's permissions on the share. This issue has been patched in version 9.1.0.

Affected products (as reported)

VendorProductVersions
kiteworks security-advisories < 9.1.0

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

References