Vulnerability · Published Jul 6, 2026 · Assigned by GitHub_M
CVE-2025-53831DrawIO for ownCloud 10 is vulnerable to Stored XSS
High 8.2
In plain English
A high-severity cross-site scripting in DrawIO for ownCloud from owncloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities).
Official description
DrawIO for ownCloud is an application for using DrawIO with the file storage, synchronization, and sharing application ownCloud Classic. In DrawIO for ownCloud prior to version 1.0.2, which corresponds to ownCloud 10 prior to version 10.15.3, attackers with access to the DrawIO app can leverage improper neutralization of input during web page generation to achieve stored XSS. Upgrade ownCloud 10 to version 10.15.3 or later or upgrade DrawIO for ownCloud 10 to version 1.0.2 or later to receive a patch.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| owncloud | DrawIO for ownCloud | < 1.0.2 |
| owncloud | ownCloud 10 | < 10.15.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L