Vulnerability · Published Jul 14, 2025 · Assigned by GitHub_M

CVE-2025-53623Job Iteration API is vulnerable to OS Command Injection attack through its CsvEnumerator class

High 8.1

In plain English

A high-severity OS command injection in job-iteration from Shopify. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.1High
Exploit odds (30 days)0.8%top 42.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The Job Iteration API is an an extension for ActiveJob that make jobs interruptible and resumable Versions prior to 1.11.0 have an arbitrary code execution vulnerability in the `CsvEnumerator` class. This vulnerability can be exploited by an attacker to execute arbitrary commands on the system where the application is running, potentially leading to unauthorized access, data leakage, or complete system compromise. The issue is fixed in versions `1.11.0` and above. Users can mitigate the risk by avoiding the use of untrusted input in the `CsvEnumerator` class and ensuring that any file paths are properly sanitized and validated before being passed to the class methods. Users should avoid using the `count_of_rows_in_file` method with untrusted CSV filenames.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsjob-iteration1.11GHSA-6qjf-g333-pv38

Affected products (as reported)

VendorProductVersions
Shopify job-iteration < 1.11.0

Weakness: CWE-78 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

References