Vulnerability · Published Jul 21, 2025 · Assigned by GitHub_M
CVE-2025-53528Cadwyn is vulnerable to an XSS attack through its docs page
High 7.6
In plain English
A high-severity cross-site scripting in cadwyn from zmievsa. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Cadwyn creates production-ready community-driven modern Stripe-like API versioning in FastAPI. In versions before 5.4.3, the version parameter of the "/docs" endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack. This XSS would notably allow an attacker to execute JavaScript code on a user's session for any application based on Cadwyn via a one-click attack. The vulnerability has been fixed in version 5.4.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | cadwyn | 5.4.3 | GHSA-2gxp-6r36-m97r |
| PyPI | cadwyn | 5.4.3 | PYSEC-2025-71 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L