Vulnerability · Published Aug 23, 2025 · Assigned by @huntr_ai
CVE-2025-5352Environment Variable XSS in Analytics Component in lunary-ai/lunary
High 8.1
In plain English
A high-severity cross-site scripting in lunary-ai/lunary from lunary-ai. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code.
Official description
A critical stored Cross-Site Scripting (XSS) vulnerability exists in the Analytics component of lunary-ai/lunary versions up to 1.9.23, where the NEXT_PUBLIC_CUSTOM_SCRIPT environment variable is directly injected into the DOM using dangerouslySetInnerHTML without any sanitization or validation. This allows arbitrary JavaScript execution in all users' browsers if an attacker can control the environment variable during deployment or through server compromise. The vulnerability can lead to complete account takeover, data exfiltration, malware distribution, and persistent attacks affecting all users until the environment variable is cleaned. The issue is fixed in version 1.9.25.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| lunary-ai | lunary-ai/lunary | unspecified – before 1.9.25 |
Weakness: CWE-79 · Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H