Vulnerability · Published Jul 10, 2025 · Assigned by apache
CVE-2025-53506Apache Tomcat: DoS via excessive h2 streams at connection start
High 7.5
In plain English
A high-severity uncontrolled resource consumption in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.1% (higher than 82% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Uncontrolled Resource Consumption vulnerability in Apache Tomcat if an HTTP/2 client did not acknowledge the initial settings frame that reduces the maximum permitted concurrent streams. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | tomcat | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-admin-webapps | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-admin-webapps | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-docs-webapp | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-docs-webapp | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-el-3.0-api | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-el-3.0-api | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-jsp-2.3-api | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-jsp-2.3-api | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-lib | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-lib | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-servlet-4.0-api | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-servlet-4.0-api | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-webapps | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-webapps | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:10 | tomcat9 | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-admin-webapps | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-docs-webapp | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-el-3.0-api | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-jsp-2.3-api | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-lib | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-servlet-4.0-api | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-webapps | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| Debian:12 | tomcat10 | 10.1.52-1~deb12u1 | DEBIAN-CVE-2025-53506 |
| Debian:12 | tomcat10 | 10.1.52-1~deb12u1 | DSA-6120-1 |
| Debian:13 | tomcat10 | 10.1.52-1~deb13u1 | DEBIAN-CVE-2025-53506 |
| Debian:13 | tomcat10 | 10.1.52-1~deb13u1 | DSA-6120-1 |
| Debian:14 | tomcat10 | 10.1.46-1 | DEBIAN-CVE-2025-53506 |
| Debian:13 | tomcat11 | 11.0.15-1~deb13u1 | DSA-6121-1 |
| Debian:13 | tomcat11 | 11.0.15-1~deb13u1 | DEBIAN-CVE-2025-53506 |
| Debian:14 | tomcat11 | 11.0.11-1 | DEBIAN-CVE-2025-53506 |
| Debian:12 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-53506 |
| Debian:13 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-53506 |
| Debian:14 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-53506 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 9.0.107 | GHSA-25xr-qj8w-c4vf |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 10.1.43 | GHSA-25xr-qj8w-c4vf |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 11.0.9 | GHSA-25xr-qj8w-c4vf |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | no fix listed | GHSA-25xr-qj8w-c4vf |
| Maven | org.apache.tomcat:tomcat-coyote | 11.0.9 | GHSA-25xr-qj8w-c4vf |
| Maven | org.apache.tomcat:tomcat-coyote | 9.0.107 | GHSA-25xr-qj8w-c4vf |
| Maven | org.apache.tomcat:tomcat-coyote | no fix listed | GHSA-25xr-qj8w-c4vf |
| Maven | org.apache.tomcat:tomcat-coyote | 10.1.43 | GHSA-25xr-qj8w-c4vf |
| Rocky Linux:10 | tomcat | 1:10.1.36-1.el10_0.2 | RLSA-2025:14179 |
| Rocky Linux:8 | tomcat | 1:9.0.87-1.el8_10.6 | RLSA-2025:14177 |
| Rocky Linux:9 | tomcat | 1:9.0.87-3.el9_6.3 | RLSA-2025:14181 |
| Rocky Linux:10 | tomcat9 | 1:9.0.87-5.el10_0.3 | RLSA-2025:14178 |
| Ubuntu:24.04:LTS | tomcat10 | no fix listed | UBUNTU-CVE-2025-53506 |
| Ubuntu:25.10 | tomcat10 | no fix listed | UBUNTU-CVE-2025-53506 |
| Ubuntu:26.04:LTS | tomcat10 | no fix listed | UBUNTU-CVE-2025-53506 |
| Ubuntu:26.10 | tomcat10 | no fix listed | UBUNTU-CVE-2025-53506 |
| Ubuntu:25.10 | tomcat11 | no fix listed | UBUNTU-CVE-2025-53506 |
| Ubuntu:26.04:LTS | tomcat11 | no fix listed | UBUNTU-CVE-2025-53506 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Tomcat | 11.0.0-M1 – through 11.0.810.1.0-M1 – through 10.1.429.0.0.M1 – through 9.0.1068.5.0 – through 8.5.100 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H