Vulnerability · Published Jul 3, 2025 · Assigned by GitHub_M

CVE-2025-53370Citizen stored XSS vulnerability through short descriptions

High 8.6

In plain English

A high-severity cross-site scripting in mediawiki-skins-Citizen from StarCitizenTools. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)0.4%top 67.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. From versions 1.9.4 to before 3.4.0, short descriptions set via the ShortDescription extension are inserted as raw HTML by the Citizen skin, allowing any user to insert arbitrary HTML into the DOM by editing a page. This issue has been patched in version 3.4.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagiststarcitizentools/citizen-skin3.4.0GHSA-prmv-7r8c-794g

Affected products (as reported)

VendorProductVersions
StarCitizenTools mediawiki-skins-Citizen >= 65a7ffd927467c8c3557146d1ac6de62b0369b6c, < c85a40bddc8651fff66df83a72debddcb34f0521>= 1.9.4, < 3.4.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

References