Vulnerability · Published Jul 3, 2025 · Assigned by GitHub_M
CVE-2025-53368Citizen is vulnerable to stored XSS attack in the legacy search bar
High 8.6
In plain English
A high-severity cross-site scripting in mediawiki-skins-Citizen from StarCitizenTools. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. From versions 1.9.4 to before 3.4.0, page descriptions are inserted into raw HTML without proper sanitization by the Citizen skin when using the old search bar. Any user with page editing privileges can insert cross-site scripting (XSS) payloads into the DOM for other users who are searching for specific pages. This issue has been patched in version 3.4.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | starcitizentools/citizen-skin | 3.4.0 | GHSA-rq6g-6g94-jfr4 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| StarCitizenTools | mediawiki-skins-Citizen | >= 1.9.4, < 3.4.0>= b2bd79196db1153d0bc1bd51a646d957cbdf4aec, < aedbceb3380bb48db6b59e272fc187529c71c8ca |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
References
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/security/advisories/GHSA-rq6g-6g94-jfr4 x_refsource_CONFIRM
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/aedbceb3380bb48db6b59e272fc187529c71c8ca x_refsource_MISC
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/releases/tag/v3.4.0 x_refsource_MISC