Vulnerability · Published Jul 3, 2025 · Assigned by GitHub_M

CVE-2025-53367DjVuLibre OOB-Write Vulnerability in MMRDecoder

High 8.4

In plain English

A high-severity out-of-bounds write in DjVuLibre from DjvuNet. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.4High
Exploit odds (30 days)0.9%top 41.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Public PoC

Official description

DjVuLibre is a GPL implementation of DjVu, a web-centric format for distributing documents and images. Prior to version 3.5.29, the MMRDecoder::scanruns method is affected by an OOB-write vulnerability, because it does not check that the xr pointer stays within the bounds of the allocated buffer. This can lead to writes beyond the allocated memory, resulting in a heap corruption condition. An out-of-bounds read with pr is also possible for the same reason. This issue has been patched in version 3.5.29.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12djvulibre3.5.28-2.1~deb12u1DSA-5960-1
Debian:12djvulibre3.5.28-2.1~deb12u1DEBIAN-CVE-2025-53367
Debian:13djvulibre3.5.28-2.1DEBIAN-CVE-2025-53367
Debian:14djvulibre3.5.28-2.1DEBIAN-CVE-2025-53367
Ubuntu:22.04:LTSdjvulibre3.5.28-2ubuntu0.22.04.1USN-7631-1
Ubuntu:22.04:LTSdjvulibre3.5.28-2ubuntu0.22.04.1UBUNTU-CVE-2025-53367
Ubuntu:24.04:LTSdjvulibre3.5.28-2ubuntu0.24.04.1USN-7631-1
Ubuntu:24.04:LTSdjvulibre3.5.28-2ubuntu0.24.04.1UBUNTU-CVE-2025-53367

Affected products (as reported)

VendorProductVersions
DjvuNet DjVuLibre < 3.5.29

Weakness: CWE-787, CWE-125 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References