Vulnerability · Published Jul 8, 2025 · Assigned by GitHub_M
CVE-2025-53355mcp-server-kubernetes vulnerable to command injection in several tools
High 7.5
In plain English
A high-severity command injection in mcp-server-kubernetes from Flux159. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 2.2% (higher than 83% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
MCP Server Kubernetes is an MCP Server that can connect to a Kubernetes cluster and manage it. A command injection vulnerability exists in the mcp-server-kubernetes MCP Server. The vulnerability is caused by the unsanitized use of input parameters within a call to child_process.execSync, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. This vulnerability is fixed in 2.5.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | mcp-server-kubernetes | 2.5.0 | GHSA-gjv4-ghm7-q58q |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Flux159 | mcp-server-kubernetes | < 2.5.0 |
Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/Flux159/mcp-server-kubernetes/security/advisories/GHSA-gjv4-ghm7-q58q x_refsource_CONFIRM
- https://github.com/Flux159/mcp-server-kubernetes/commit/ab165f5a0eea917fef5dbae954506fff6f4bf514 x_refsource_MISC
- https://github.com/cyanheads/git-mcp-server/commit/0dbd6995ccdf76ab770b58013034365b2d06c4d9 x_refsource_MISC