Vulnerability · Published Jul 1, 2025 · Assigned by GitHub_M

CVE-2025-53107@cyanheads/git-mcp-server vulnerable to command injection in several tools

High 7.5

In plain English

A high-severity command injection in git-mcp-server from cyanheads. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 24.5% (higher than 98% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)24.5%top 2.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

@cyanheads/git-mcp-server is an MCP server designed to interact with Git repositories. Prior to version 2.1.5, there is a command injection vulnerability caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). An MCP Client can be instructed to execute additional actions for example via indirect prompt injection when asked to read git logs. This issue has been patched in version 2.1.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@cyanheads/git-mcp-server2.1.5GHSA-3q26-f695-pp76

Affected products (as reported)

VendorProductVersions
cyanheads git-mcp-server < 2.1.5

Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

References