Vulnerability · Published Oct 16, 2025 · Assigned by GitHub_M
CVE-2025-53092Strapi core vulnerable to sensitive data exposure via CORS misconfiguration
Medium 6.5
In plain English
A medium-severity information exposure in strapi from strapi. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Strapi is an open source headless content management system. Strapi versions prior to 5.20.0 contain a CORS misconfiguration vulnerability in default installations. By default, Strapi reflects the value of the Origin header back in the Access-Control-Allow-Origin response header without proper validation or whitelisting. This allows an attacker-controlled site to send credentialed requests to the Strapi backend. An attacker can exploit this by hosting a malicious site on a different origin (e.g., different port) and sending requests with credentials to the Strapi API. The vulnerability is fixed in version 5.20.0. No known workarounds exist.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @strapi/core | 5.20.0 | GHSA-9329-mxxw-qwf8 |
Affected products (as reported)
Weakness: CWE-200, CWE-284, CWE-364, CWE-942 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
References
- https://github.com/strapi/strapi/security/advisories/GHSA-9329-mxxw-qwf8 x_refsource_CONFIRM