Vulnerability · Published Jul 10, 2025 · Assigned by apache

CVE-2025-53020Apache HTTP Server: HTTP/2 DoS by Memory Increase

High 7.5

In plain English

A high-severity memory leak in Apache HTTP Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 5.0% (higher than 92% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)5.0%top 7.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Late Release of Memory after Effective Lifetime vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: from 2.4.17 up to 2.4.63. Users are recommended to upgrade to version 2.4.64, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8httpd2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:8httpd-devel2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:8httpd-filesystem2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:8httpd-manual2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:8httpd-tools2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:10mod_http22.0.29-4.el10_2ALSA-2026:22528
AlmaLinux:8mod_http21.15.7-10.module_el8.10.0+4185+0955a0d7.5ALSA-2026:22140
AlmaLinux:9mod_http22.0.26-6.el9_8ALSA-2026:22551
AlmaLinux:8mod_ldap2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:8mod_md1:2.0.8-8.module_el8.10.0+4088+57f011c1.2ALSA-2026:22140
AlmaLinux:8mod_proxy_html1:2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:8mod_session2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:8mod_ssl1:2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
Alpine:v3.20apache22.4.64-r0ALPINE-CVE-2025-53020
Alpine:v3.21apache22.4.64-r0ALPINE-CVE-2025-53020
Alpine:v3.22apache22.4.64-r0ALPINE-CVE-2025-53020
Alpine:v3.23apache22.4.64-r0ALPINE-CVE-2025-53020
Alpine:v3.24apache22.4.64-r0ALPINE-CVE-2025-53020
Debian:12apache22.4.65-1~deb12u1DEBIAN-CVE-2025-53020
Debian:13apache22.4.64-1DEBIAN-CVE-2025-53020
Debian:14apache22.4.64-1DEBIAN-CVE-2025-53020
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1938+3b7755d4.3RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1842+4a9649e8.2RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1840+b070a976.1RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+40053+5a18018e.7RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+40045+6ce8579b.6RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+2061+8d03fdec.5RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1830+22f0c9e0RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1984+1bed3124.4RLSA-2026:22140
Rocky Linux:10mod_http20:2.0.29-4.el10_2RLSA-2026:22528
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1775+6b057638RLSA-2026:22140
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1830+22f0c9e0RLSA-2026:22140
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1883+38ed6c58.1RLSA-2026:22140
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1938+3b7755d4.3RLSA-2026:22140
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+2061+8d03fdec.4RLSA-2026:22140
Rocky Linux:9mod_http20:2.0.26-6.el9_8RLSA-2026:22551
Rocky Linux:8mod_md1:2.0.8-8.module+el8.10.0+40053+5a18018e.2RLSA-2026:22140
Rocky Linux:8mod_md1:2.0.8-8.module+el8.9.0+1370+89cc8ad5RLSA-2026:22140
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.15UBUNTU-CVE-2025-53020
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.15USN-7639-1
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.7USN-7639-1
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.7UBUNTU-CVE-2025-53020

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache HTTP Server 2.4.17 – through 2.4.63

Weakness: CWE-401 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References