Vulnerability · Published Aug 25, 2025 · Assigned by @huntr_ai

CVE-2025-5302Denial of Service (DOS) in JSONReader in run-llama/llama_index

High 8.6

In plain English

A high-severity security flaw in run-llama/llama_index from run-llama. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.0)8.6High
Exploit odds (30 days)0.3%top 78.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIllama-index-core0.12.38GHSA-7753-xrfw-ch36
PyPIllama-index-core0.12.38PYSEC-2026-1561

Affected products (as reported)

VendorProductVersions
run-llama run-llama/llama_index unspecified – before 0.12.38

Weakness: CWE-674 · Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

References