Vulnerability · Published Aug 5, 2025 · Assigned by GitHub_M

CVE-2025-52892EspoCRM is vulnerable to access denial through double slash in URI corrupting router cache

Medium 4.5

In plain English

A medium-severity security flaw in espocrm from espocrm. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities).

Severity (CVSS 3.1)4.5Medium
Exploit odds (30 days)0.3%top 79.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

EspoCRM is a web application with a frontend designed as a single-page application and a REST API backend written in PHP. In versions 9.1.6 and below, if a user loads Espo in the browser with double slashes (e.g https://domain//#Admin) and the webserver does not strip the double slash, it can cause a corrupted Slim router's cache. This will make the instance unusable until there is a completed rebuild. This is fixed in version 9.1.7.

Affected products (as reported)

VendorProductVersions
espocrm espocrm < 9.1.7

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:H

References