Vulnerability · Published Jun 24, 2025 · Assigned by GitHub_M
CVE-2025-52568NeKernal Multiple Memory Corruption Vulnerabilities in mkfs.hefs
High 8.8
In plain English
A high-severity improper input validation in nekernel from nekernel-org. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities).
Official description
NeKernal is a free and open-source operating system stack. Prior to version 0.0.3, there are several memory safety issues that can lead to memory corruption, disk image corruption, denial of service, and potential code execution. These issues stem from unchecked memory operations, unsafe typecasting, and improper input validation. This issue has been patched in version 0.0.3.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nekernel-org | nekernel | < 0.0.3 |
Weakness: CWE-20, CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/nekernel-org/nekernel/security/advisories/GHSA-cmp2-5f6g-mw34 x_refsource_CONFIRM
- https://github.com/nekernel-org/nekernel/pull/35 x_refsource_MISC
- https://github.com/nekernel-org/nekernel/pull/36 x_refsource_MISC
- https://github.com/nekernel-org/nekernel/commit/6506875ad0ab210b82a5c4ce227bf851508de17d x_refsource_MISC
- https://github.com/nekernel-org/nekernel/commit/6511afbf405c31513bc88ab06bca58218610a994 x_refsource_MISC