Vulnerability · Published Jun 23, 2025 · Assigned by GitHub_M

CVE-2025-52562Convey Panel Directory Traversal in LocaleController leading to Remote Code Execution

Critical 10.0

In plain English

A critical-severity path traversal in panel from ConvoyPanel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 79% of all known vulnerabilities).

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)1.8%top 21.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Convoy is a KVM server management panel for hosting businesses. In versions 3.9.0-rc3 to before 4.4.1, there is a directory traversal vulnerability in the LocaleController component of Performave Convoy. An unauthenticated remote attacker can exploit this vulnerability by sending a specially crafted HTTP request with malicious locale and namespace parameters. This allows the attacker to include and execute arbitrary PHP files on the server. This issue has been patched in version 4.4.1. A temporary workaround involves implementing strict Web Application Firewall (WAF) rules to incoming requests targeting the vulnerable endpoints.

Affected products (as reported)

VendorProductVersions
ConvoyPanel panel >= 3.9.0-rc.3, < 4.4.1

Weakness: CWE-22, CWE-98 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

References