Vulnerability · Published May 24, 2025 · Assigned by VulDB
CVE-2025-5127Teledyne FLIR AX8 prod.php cross site scripting
Low 3.5
In plain English
A low-severity cross-site scripting in AX8 from Teledyne FLIR. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities).
Official description
A vulnerability was determined in Teledyne FLIR AX8 up to 1.46.16. This issue affects some unknown processing of the file /prod.php. Executing manipulation of the argument cmd can lead to cross site scripting. The attack may be launched remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 1.49.16 is capable of addressing this issue. It is recommended to upgrade the affected component. The vendor points out: "FLIR AX8 internal web site has been refactored to be able to handle the reported vulnerabilities."
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Teledyne FLIR | AX8 | 1.46.01.46.11.46.21.46.31.46.41.46.51.46.61.46.7 |
Weakness: CWE-79, CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N/E:P/RL:O/RC:C
References
- VDB-310205 | Teledyne FLIR AX8 prod.php cross site scripting vdb-entry, technical-description
- VDB-310205 | CTI Indicators (IOB, IOC, TTP, IOA) signature, permissions-required
- Submit #572265 | FLIR AX8 <= 1.46 XSS third-party-advisory
- https://github.com/YZS17/CVE/blob/main/XSS%20vulnerability%20in%20FLIR%20AX8.md broken-link, exploit