Vulnerability · Published Jun 17, 2025 · Assigned by GitHub_M
CVE-2025-49842conda-forge-webservices Privilege Escalation Risk via Default Docker Root User
Low 1.0
In plain English
A low-severity incorrect default permissions in conda-forge-webservices from conda-forge. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities).
Official description
conda-forge-webservices is the web app deployed to run conda-forge admin commands and linting. Prior to version 2025.3.24, the conda_forge_webservice Docker container executes commands without specifying a user. By default, Docker containers run as the root user, which increases the risk of privilege escalation and host compromise if a vulnerability is exploited. This issue has been patched in version 2025.3.24.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| conda-forge | conda-forge-webservices | < 2025.3.24 |
Weakness: CWE-276 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:U